Subscribe to XML Feed
26 Feb 2010

Steps to replace bundler 0.8 with bundler08

If you got errors like this:

willy@extensa projects $ padrino –help
/usr/lib/ruby/1.8/rubygems.rb:280:in ‘activate’: can’t activate bundler (= 0.9.7, runtime) for [“padrino-core-0.9.1”], already activated bundler-0.8.1 for [] (Gem::LoadError)

After upgrading Bundler:

willy@extensa projects $ sudo gem update bundler
Updating installed gems
Updating bundler
Due to a rubygems bug, you must uninstall older versions of the bundler gem for 0.9 to work.
If you still need bundler 0.8, install the ‘bundler08’ gem.
Successfully installed bundler-0.9.9
Gems updated: bundler

It is easier to update all your gems, but for gems still using 0.8 like appengine-tools, here are my brilliant steps :)

  1. Install bunder08
  2. Search for bundler occurences:
    cd /var/lib/gems/1.8/specifications
    (wherever your path is..)
    egrep "<bundler>.+?0\.8" *
  3. Replace only the first occurences of them
    (all of them to be safe if you’re using ancient Rubygems)
  4. Uninstall bundler 0.8
View Comments
25 Feb 2010

Moving Github Watched Repos to Delicious